Making webpart ajax enabled


<File Path="Masters\City.aspx" Url="Masters/City.aspx" ReplaceContent="TRUE">
      <View List="Lists/Cities" BaseViewID="1" WebPartZoneID="wpzCityModule" WebPartOrder="1">
        <![CDATA[
          <webParts>
              <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
                  <metaData>
                      <type name="Microsoft.SharePoint.WebPartPages.XsltListViewWebPart,Microsoft.SharePoint,Version=14.0.0.0,Culture=neutral,PublicKeyToken=71e9bce111e9429c" />
                      <importErrorMessage>Cannot import this Web Part.</importErrorMessage>
                  </metaData>
                  <data>
                      <properties>
                          <property name="Title" type="string">My Tasks</property>
                          <property name="AllowMinimize" type="bool">True</property>                          
                          <property name="InplaceSearchEnabled" type="bool">True</property>
                          <property name="ShowToolbarWithRibbon" type="bool">False</property>
                      </properties>
                  </data>
              </webPart>
          </webParts>
      ]]>
      </View>
    </File>
    </File>

<WebPartPages:WebPartZone runat="server" FrameType="None" ID="wpzCityModule">
	<ZoneTemplate></ZoneTemplate>
</WebPartPages:WebPartZone>
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s